re = /(?<=^<para styleclass="Table Row Heading Text">)(?:[^<]*)(<.*)(?=<\/para>)/
str = '<para styleclass="Table Row Heading Text">some text<text style="font-size:12pt;">iso.outgoingQueueNameas</text></para>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end