const regex = /(?<=^<para styleclass="Table Row Heading Text">)(?:[^<]*)(<.*)(?=<\/para>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^<para styleclass="Table Row Heading Text">)(?:[^<]*)(<.*)(?=<\\\/para>)', 'g')
const str = `<para styleclass="Table Row Heading Text">some text<text style="font-size:12pt;">iso.outgoingQueueNameas</text></para>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}