using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<result>(?!\s)(.*?)(\s\2)+)";
string input = @"hello hello hello I am I am I am your string string string string of strings";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}