re = /(?<result>(?!\s)(.*?)(\s\2)+)/
str = 'hello hello hello I am I am I am your string string string string of strings'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end