$re = '/(?<result>(?!\s)(.*?)(\s\2)+)/';
$str = 'hello hello hello I am I am I am your string string string string of strings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);