import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\[a-zA-Z0-9]*\\s?";
final String string = "\n"
+ " \\fs14 (font size 14)\n"
+ " \\ri240 (right indent)\n"
+ " \\lang1033 (applies a language to a character)\n"
+ "\\ \n"
+ "\\\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}