// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\[a-zA-Z0-9]*\s?").unwrap();
let string = "
\\fs14 (font size 14)
\\ri240 (right indent)
\\lang1033 (applies a language to a character)
\\
\\
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}