const regex = /^(0\.[5-9])\d{0,7}$|^([1-9]{1})\.?\d{0,8}$|^[0-9]{2,3}\.?\d{0,8}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0\\.[5-9])\\d{0,7}$|^([1-9]{1})\\.?\\d{0,8}$|^[0-9]{2,3}\\.?\\d{0,8}$', '')
const str = `1000.12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}