// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(0\.[5-9])\d{0,7}$|^([1-9]{1})\.?\d{0,8}$|^[0-9]{2,3}\.?\d{0,8}$").unwrap();
let string = "1000.12345678";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}