$re = '/^(0\.[5-9])\d{0,7}$|^([1-9]{1})\.?\d{0,8}$|^[0-9]{2,3}\.?\d{0,8}$/';
$str = '1000.12345678';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);