using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)([A-G]m?)(?=\s)";
string input = @" D A Bm
I could stay awake just to hear you breathing
G D Em
Watch you smile while you are sleeping while your far away
A
dreaming
D A Bm
I could spend my life in this sweet surrender
G D Em
I could stay lost in this moment forever
A G A
Every moment spent with you is a moment I treasure
Chorus:
D A
I don't want to close my eyes";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}