$re = '/(?<=\s)([A-G]m?)(?=\s)/m';
$str = ' D A Bm
I could stay awake just to hear you breathing
G D Em
Watch you smile while you are sleeping while your far away
A
dreaming
D A Bm
I could spend my life in this sweet surrender
G D Em
I could stay lost in this moment forever
A G A
Every moment spent with you is a moment I treasure
Chorus:
D A
I don\'t want to close my eyes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);