const regex = /(?<=\s)([A-G]m?)(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)([A-G]m?)(?=\\s)', 'gm')
const str = ` D A Bm
I could stay awake just to hear you breathing
G D Em
Watch you smile while you are sleeping while your far away
A
dreaming
D A Bm
I could spend my life in this sweet surrender
G D Em
I could stay lost in this moment forever
A G A
Every moment spent with you is a moment I treasure
Chorus:
D A
I don't want to close my eyes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}