package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(\.\d{0,4})?$`)
var str = `1
1.2
1.23
1.234
1.2345
9.
10
10.1
1.23456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}