import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d(\\.\\d{0,4})?$";
final String string = "1\n\n"
+ "1.2\n\n"
+ "1.23\n\n"
+ "1.234\n\n"
+ "1.2345\n\n"
+ "9.\n\n"
+ "10\n\n"
+ "10.1\n\n"
+ "1.23456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}