$re = '/^\d(\.\d{0,4})?$/m';
$str = '1
1.2
1.23
1.234
1.2345
9.
10
10.1
1.23456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);