use strict;
my $str = '@extends(\'layouts/default\')
@section(\'content\')
<div class="row">
<div class="col-md-6">
@embed(\'components/box\')
@section(\'title\', \'Box title\')
@section(\'content\')
<h4>Haai</h4>
Box content
@stop
@endembed
</div>
<div class="col-md-6">
@embed(\'components/box\')
@section(\'title\', \'Box2 title\')
@section(\'content\')
@embed(\'components/timeline\')
@section(\'items\')
@stop
@endembed
@stop
@endembed
</div>
</div>
@stop';
my $regex = qr/(?=(@embed(?:(?>(?:(?!@embed|@endembed).)+)*|(?1))*@endembed))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}