using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)([( ])(.*)\)*(\.decode\((.*[""'].*?[""'].*)\))";
string substitution = @"$1$2decode_p2( $3 ,$5 )";
string input = @" valami.decode(""utf-8"", ""replace"")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}