package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))`)
var str = ` valami.decode("utf-8", "replace")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')`
var substitution = "$1$2decode_p2( $3 ,$5 )"
fmt.Println(re.ReplaceAllString(str, substitution))
}