import re
regex = re.compile(r"(.*)([( ])(.*)\)*(\.decode\((.*[\"'].*?[\"'].*)\))", flags=re.MULTILINE)
test_str = (" valami.decode(\"utf-8\", \"replace\")\n"
"str(temp[0].decode('utf-8'))\n"
"asd(str(temp[0].decode('Windows-1250'))) qwe\n"
"s += str(args[i]).decode('windows-1250', 'replace')")
subst = "$1$2decode_p2( $3 ,$5 )"
result = regex.sub(subst, test_str)
if result:
print(result)