import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$?(?:,?\\d){1,8}(?:\\.\\d{1,2})?$";
final String string = "99999999.99\n"
+ "$99999999.99\n"
+ "$9,999,9999.99\n"
+ "$9999,99,99.99\n"
+ "$999999999.99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}