re = /^\$?(?:,?\d){1,8}(?:\.\d{1,2})?$/m
str = '99999999.99
$99999999.99
$9,999,9999.99
$9999,99,99.99
$999999999.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end