$re = '/^\$?(?:,?\d){1,8}(?:\.\d{1,2})?$/m';
$str = '99999999.99
$99999999.99
$9,999,9999.99
$9999,99,99.99
$999999999.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);