package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(label(:|\+))?(\w+)(?:_(\d+))?`)
var str = `group_12.label:sub_1.field_23.label+long_field.label:another.label+long_field_345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}