// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(label(:|\+))?(\w+)(?:_(\d+))?").unwrap();
let string = "group_12.label:sub_1.field_23.label+long_field.label:another.label+long_field_345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}