using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([a-zA-Z0-9_\-]+?)\](.+?)\[\/\1\]";
string input = @"[b][u]azazeaze[/u][/b] [i]aaaaaaaaaaaaaa[/i]";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}