$re = '/\[([a-zA-Z0-9_\-]+?)\](.+?)\[\/\1\]/im';
$str = '[b][u]azazeaze[/u][/b] [i]aaaaaaaaaaaaaa[/i]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);