re = /\[([a-zA-Z0-9_\-]+?)\](.+?)\[\/\1\]/im
str = '[b][u]azazeaze[/u][/b] [i]aaaaaaaaaaaaaa[/i]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end