import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">(occurence(?:\\s(?:[\\w']+),?){0,100})|((?:\\s(?:[\\w']+)){0,100}\\s?occurence(?:\\s(?:[\\w']+),?){0,100})|((?:\\s(?:[\\w',]+)){0,100}\\s?occurence)<";
final String string = "<p>Do not forget the error handling, I don't exactly know what happens if it wants to replace an occurence and can't find it</p>\n"
+ "<p>Edit: If you have multiple entries which should be replaced, loop the replace part until it will not be able to replace anymore then it will throw an error you can catch to continue</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}