const regex = />(occurence(?:\s(?:[\w']+),?){0,100})|((?:\s(?:[\w']+)){0,100}\s?occurence(?:\s(?:[\w']+),?){0,100})|((?:\s(?:[\w',]+)){0,100}\s?occurence)</;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>(occurence(?:\\s(?:[\\w\']+),?){0,100})|((?:\\s(?:[\\w\']+)){0,100}\\s?occurence(?:\\s(?:[\\w\']+),?){0,100})|((?:\\s(?:[\\w\',]+)){0,100}\\s?occurence)<', '')
const str = `<p>Do not forget the error handling, I don't exactly know what happens if it wants to replace an occurence and can't find it</p>
<p>Edit: If you have multiple entries which should be replaced, loop the replace part until it will not be able to replace anymore then it will throw an error you can catch to continue</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}