re = />(occurence(?:\s(?:[\w']+),?){0,100})|((?:\s(?:[\w']+)){0,100}\s?occurence(?:\s(?:[\w']+),?){0,100})|((?:\s(?:[\w',]+)){0,100}\s?occurence)</
str = '<p>Do not forget the error handling, I don\'t exactly know what happens if it wants to replace an occurence and can\'t find it</p>
<p>Edit: If you have multiple entries which should be replaced, loop the replace part until it will not be able to replace anymore then it will throw an error you can catch to continue</p>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end