# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-z0-9$¢£€¥ ]+//gui;t' <<< "‚£5 off bookings at A1Travel"