package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Copyright © \d{4}$`)
var str = `Copyright © 2011
Copyright © 2011
Copyright © 2011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}