re = /^Copyright © \d{4}$/m
str = 'Copyright © 2011
Copyright © 2011
Copyright © 2011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end