const regex = /^[\w\.\-]+\+[0-9]+@[\w\-\.]+\.[a-z]{2,4}$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w\\.\\-]+\\+[0-9]+@[\\w\\-\\.]+\\.[a-z]{2,4}$', 'i')
const str = `testtest+151@hotmail.co.uk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}