$re = '/^[\w\.\-]+\+[0-9]+@[\w\-\.]+\.[a-z]{2,4}$/i';
$str = 'testtest+151@hotmail.co.uk';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);