re = /^[\w\.\-]+\+[0-9]+@[\w\-\.]+\.[a-z]{2,4}$/i
str = 'testtest+151@hotmail.co.uk'
# Print the match result
str.match(re) do |match|
puts match.to_s
end