using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=.\W|\W.|^\W|):loul:(?=.\W|\W.|\W$|)";
string input = @"Ah c'est super !
:loul:";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}