$re = '/(?<=.\W|\W.|^\W|):loul:(?=.\W|\W.|\W$|)/';
$str = 'Ah c\'est super !
:loul:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);