using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<=[a-z])\[[^\[\]]*\]";
string input = @"a[1170]
[1170]
[1170]
343[1170]
.[1170]
a[[1170]
[a[1170]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}