$re = '/(?i)(?<=[a-z])\[[^\[\]]*\]/m';
$str = 'a[1170]
[1170]
[1170]
343[1170]
.[1170]
a[[1170]
[a[1170]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);