import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<=[a-z])\\[[^\\[\\]]*\\]";
final String string = "a[1170]\n"
+ "[1170]\n"
+ " [1170]\n"
+ "343[1170]\n"
+ ".[1170]\n"
+ "a[[1170]\n"
+ "[a[1170]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}