use strict;
my $str = 'Add "email@sad.com"';
my $regex = qr/(?:Add|[\"]|[\s])/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";