using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<\?php\s)(.*?)(?=\?>)";
string input = @"<div id=""test"">Hello World!</div><?php echo ""Hello World!""?>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}