re = /(?<=<\?php\s)(.*?)(?=\?>)/
str = '<div id="test">Hello World!</div><?php echo "Hello World!"?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end