$re = '/(?<=<\?php\s)(.*?)(?=\?>)/';
$str = '<div id="test">Hello World!</div><?php echo "Hello World!"?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);