const regex = /(?:(?<h>\d?\d) час)?(?:(?<m>\d?\d) мин)?(?:(?<s>\d?\d) сек)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<h>\\d?\\d) час)?(?:(?<m>\\d?\\d) мин)?(?:(?<s>\\d?\\d) сек)?', 'g')
const str = `Попробуйте снова через 1 часа 11 минут 46 секунд`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}