$re = '/(?:(?<h>\d?\d) час)?(?:(?<m>\d?\d) мин)?(?:(?<s>\d?\d) сек)?/';
$str = 'Попробуйте снова через 1 часа 11 минут 46 секунд';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);