// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(?<h>\d?\d) час)?(?:(?<m>\d?\d) мин)?(?:(?<s>\d?\d) сек)?").unwrap();
let string = "Попробуйте снова через 1 часа 11 минут 46 секунд";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}