#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((^| )sim( |$))"
Local $sString = "Talvez não sim"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)